Slow page load times for users
Incident Report for Atlassian Bitbucket
Resolved
Bitbucket.org and our API are now responding normally.
Posted about 1 year ago. Mar 29, 2016 - 15:54 UTC
Investigating
We're receive alerts of slow page load times and API response times for some users.

We have several engineers looking into the problem. Next update will be in 45 mins.
Posted about 1 year ago. Mar 29, 2016 - 14:46 UTC
This incident affected: Website and API.