Performance problems
Incident Report for Atlassian Bitbucket
Resolved
Over the last few days we identified a series of performance problems related to the deployment of our new storage architecture. Since identifying the performance problems, we worked around the clock to correct the performance concerns. We have restored normal site, git, and mercurial performance.

Once the dust settles, we will publish a more detailed report on what happened, changes that were made, and what we've done to avoid future incidents of this nature. We will continue to monitor the situation closely and will provide updates if anything changes.

We apologize for any inconveniences this may have caused.
Posted over 3 years ago. May 01, 2014 - 22:10 UTC
Update
We are continuing to investigate performance issues and have teams working around the clock to minimize impact. We apologize for any inconvenience incurred while we work through these problems.
Posted over 3 years ago. Apr 30, 2014 - 02:23 UTC
Investigating
We are continuing to work towards identifying and mitigating issues that are causing performance problems with Bitbucket.
Posted over 3 years ago. Apr 29, 2014 - 13:49 UTC
Update
We have resolved all currently known bottlenecks and are monitoring the situation.
Posted over 3 years ago. Apr 29, 2014 - 05:35 UTC
Update
Mitigation steps have begun to help return the site to normal. We are continuing to work through additional issues, but many users will see response times improve.
Posted over 3 years ago. Apr 28, 2014 - 19:45 UTC
Update
We are continuing to work towards mitigating the issues causing performance problems with Bitbucket. We hope to have more information shortly.
Posted over 3 years ago. Apr 28, 2014 - 18:57 UTC
Identified
We've identified the major contributing factors to the slowdowns we've been experiencing today and we are taking steps to mitigate these issues.
Posted over 3 years ago. Apr 28, 2014 - 11:09 UTC