Webhooks experiencing delays
Incident Report for Atlassian Bitbucket
Resolved
Webhooks have been fully operational for the past hour. We are now working to restore request history functionality and will indicate publicly when we've done so. In the meantime, this incident is resolved as the issue that was directly negatively impacting customers (delayed webhook delivery) has been addressed.
Posted 2 months ago. Oct 12, 2018 - 19:06 UTC
Monitoring
In order to address the immediate impact of this issue we have disabled webhook request logging. Webhooks are now being delivered once again with minimal delay, but customers will notice that the request histories displayed in the UI are outdated—there will be no record of new requests.

The team is working on a solution to restore this functionality without impacting performance. We will provide another update when there is progress on that front.
Posted 2 months ago. Oct 12, 2018 - 17:26 UTC
Identified
In order to address the immediate impact of this issue we have disabled webhook request logging. Webhooks are now being delivered once again with minimal delay, but customers will notice that the request histories displayed in the UI are outdated—there will be no record of new requests.

The team is working on a solution to restore this functionality without impacting performance. We will provide another update when there is progress on that front.
Posted 2 months ago. Oct 12, 2018 - 17:20 UTC
Update
We have increased the capacity of our webhooks database to mitigate the delays we are seeing. Webhooks continue to be delivered but are currently delayed by up to 40 minutes. The team has also implemented a patch that should significantly improve performance and are in the process of getting it released. We will provide another update once the patch has been deployed.
Posted 2 months ago. Oct 12, 2018 - 16:19 UTC
Investigating
We are seeing significant delays in our webhooks service (up to 20 minutes) as a result of degraded database performance used by Webhooks. We are investigating mitigation strategies now and will provide an update when we have more information.
Posted 2 months ago. Oct 12, 2018 - 14:57 UTC
This incident affected: Webhooks.