OutOfMemory errors using Bitbucket Pipelines docker service.
Incident Report for Atlassian Bitbucket
Resolved
This incident has been resolved.
Posted 18 days ago. Nov 29, 2017 - 21:18 UTC
Monitoring
The team have deployed the fix and verified docker commands are now running as expected. We will continue to monitor the situation to ensure all failures are resolved.
Posted 19 days ago. Nov 29, 2017 - 09:46 UTC
Identified
The team has identified a problem with the previous fix and is now rolling out a new solution - many builds using docker will continue to be affected until we rollout the new solution ~ 9:15am UTC
Posted 19 days ago. Nov 29, 2017 - 08:45 UTC
Monitoring
The team has deployed a fix to Bitbucket Pipelines which allows docker commands to proceed without failure. The team will continue to monitor the situation to ensure that all failures are resolved.
Posted 19 days ago. Nov 29, 2017 - 07:12 UTC
Identified
We've received an increase in failures of pipelines using Docker. We've identified that it is caused by a change rolled out this morning, which has started enforcing a 1Gb memory limit.
We're working on increasing the limit in a safe way to remove the immediate customer impact.
Posted 19 days ago. Nov 29, 2017 - 04:33 UTC
This incident affected: Pipelines.