Bitbucket.org is experiencing heavily degraded performance
Incident Report for Atlassian Bitbucket
Resolved
We have resolved the network issue in our data center that was causing degraded performance across the platform. Performance should be back to normal shortly for all users.

We apologize for any interruption, or inconvenience this may have caused.
Posted 17 days ago. Nov 30, 2017 - 17:41 UTC
Update
We really appreciate your patience as our team continues to investigate.
Posted 17 days ago. Nov 30, 2017 - 16:38 UTC
Investigating
Our engineering team is currently investigating this issue. We will provide an update as soon as we have further information.
Posted 17 days ago. Nov 30, 2017 - 15:25 UTC